RFQ cards are not expiring properly

Major incident Trading Platform
2024-10-24 10:47 CEST · 52 minutes

Updates

Monitoring

The incident is mitigated and platform functionality is restored. We are actively monitoring the platform.

October 24, 2024 · 11:33 CEST
Monitoring

There is currently an active incident on the platform. For some customers, RFQs are not properly expiring. The incident team is aware of the problem and is actively working on a fix.

October 24, 2024 · 10:47 CEST

← Back